Xperience Cloud Platform - Major Incident

Incident Report for Xperience

Resolved

All services are now fully recovered and the platform is stable.
Posted Aug 08, 2026 - 12:19 BST

Monitoring

The core issues have been resolved and we are now monitoring for stability, and working through a small number of residual issues.

We will update again once all issues are 100% resolved.
Posted Aug 08, 2026 - 11:22 BST

Update

The majority of services are now up, and the remaining ones are still being recovered.
We will provide another update once all services are fully recovered.
Posted Aug 08, 2026 - 10:30 BST

Update

We have identified the root cause and are now working on restoring services - we will provide another update in the next 60mins.
Posted Aug 08, 2026 - 09:59 BST

Update

We are still working with the datacentre provider on this issue, and will provide another update within the next 60mins.
Posted Aug 08, 2026 - 08:47 BST

Identified

An issue has been identified which is currently impacting our Telehouse South Cloud Platform, and causing customer virtual infrastructure to become unavailable.

Our engineers are investigating the issue and an update will be provided within the next 60 mins.

If you no longer wish to receive these updates, or would like to update your preferences, please visit https://status.xperience-group.com and click 'subscribe to updates'.
Posted Aug 08, 2026 - 07:40 BST
This incident affected: Telehouse South Cloud Platform.