XPControl Platform - Outage

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 17:01 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 16:13 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2026 - 16:00 BST

Investigating

An issue with the XPControl platform has been identified and is affecting Remote Control sessions - this has been raised with the platform vendor.

Further updates will be posted here as soon as we receive them.

If you no longer wish to receive these updates, or would like to update your preferences, please visit https://status.xperience-group.com and click 'subscribe to updates'.
Posted Jul 29, 2026 - 15:39 BST
This incident affected: XPControl Platform.