Cloud Platform - Connectivity Issues

Incident Report for Xperience

Resolved

This incident has now been resolved.
Posted Apr 17, 2025 - 11:28 BST

Monitoring

Working with our upstream provider they have identified a routing issue, a fix has been put in place and we are now monitoring the situation, we will post another update within the hour.
Posted Apr 17, 2025 - 10:30 BST

Update

We are still investigating the issue and working with our upstream provider to identify the issue.
Posted Apr 17, 2025 - 09:14 BST

Investigating

We are investigating an issue which is currently impacting our [Cambridge/Meridian/Telehouse South] Cloud Platform, and causing intermittent connectivity issues

Our engineers are investigating the issue and an update will be provided within the next 60 mins.
Posted Apr 17, 2025 - 08:45 BST
This incident affected: Cambridge Cloud Platform, Meridian Cloud Platform, and Telehouse South Cloud Platform.