Further monitoring has revealed no further issues with the platform, so this incident is now resolved.
Posted Jul 01, 2026 - 12:05 BST
Monitoring
All workloads have been migrated from the affected node to alternative platform resources, and we are monitoring the overall platform performance closely.
Another update will be provided within the the next 60mins.
Posted Jul 01, 2026 - 11:07 BST
Identified
We have identified elevated performance latency on a single infrastructure node within our hosting platform, which is affecting a subset of hosted services.
To mitigate customer impact and maintain overall platform stability, we are proactively migrating workloads from the affected node to alternative platform resources.
Customers hosted on the affected infrastructure may experience periods of reduced performance while this activity is completed.
Our engineers are closely monitoring the platform and will provide a further update once the migration activity has been completed.
Posted Jul 01, 2026 - 10:07 BST
This incident affected: Telehouse South Cloud Platform.