Telehouse South Cloud Platform - Connectivity Issues

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 13:26 BST

Update

We are continuing to monitor for any further issues.
Posted Apr 09, 2026 - 11:40 BST

Monitoring

Our engineers have identified the issue and have implemented a fix and will monitor the platform.
Posted Apr 09, 2026 - 10:49 BST

Investigating

We are investigating an issue which is currently impacting our Telehouse South Cloud Platform, and causing connectivity issues

Our engineers are investigating the issue and an update will be provided within the next 60 mins.
Posted Apr 09, 2026 - 10:28 BST
This incident affected: Telehouse South Cloud Platform.