XPControl Platform - Outage

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 17:49 GMT

Monitoring

The platform vendor has implemented a fix and services are returning to normal.
Posted Mar 11, 2026 - 16:36 GMT

Update

The platform vendor has identified the issue and is currently working on a fix.
Posted Mar 11, 2026 - 13:38 GMT

Update

The platform vendor is continuing to work on the issue, and has confirmed it is an issue affecting the entire EMEA region.
Posted Mar 11, 2026 - 11:45 GMT

Identified

An issue with the XPControl platform has been identified and is affecting Remote Control sessions - this has been raised with the platform vendor who have confirmed the issue.

Further updates will be posted here as soon as we receive them.
Posted Mar 11, 2026 - 09:57 GMT
This incident affected: XPControl Platform.