XPControl Platform - Degraded performance

Incident Report for Xperience

Resolved

This has now been resolved by the vendor and we are no longer seeing any issues with connectivity.

We have been advised that any problems with connections originating from the XPRMM portal (specially, a spinning-circle when initiating a remote session), to first ensure you clear your browsers' cache and cookies, and re-launch before trying again, as this should clear the issue.

If you have any further issues relating to this, please contact the Xperience Service Desk.
Posted Mar 19, 2026 - 12:20 GMT

Monitoring

We are aware of an ongoing issue with the XPControl platform which is causing intermittent connection and performance issues with Remote Control sessions - this has been escalated with the platform vendor and we are awaiting further updates from them.

We will continue to update this page with any further developments.
Posted Mar 18, 2026 - 13:34 GMT
This incident affected: XPControl Platform.