[London] Xen Security Advisory (XSA-108)

Incident Report for Xperience

Resolved

We're pleased to confirm that this work has now been completed and that on average each customer experienced less than 12 seconds of downtime during the process due to the unique nature of our cloud platform. We appreciate your patience whilst security updates were applied, protecting your data is of paramount importance to us. Should you require any assistance with your server(s) please do not hesitate to contact our technical helpdesk for assistance.
Posted Oct 02, 2014 - 00:03 BST

Update

Engineers have now starting performing the necessary updates.
Posted Oct 01, 2014 - 22:03 BST

Identified

Engineers will be performing emergency maintenance this evening at 22:00 BST in response to the disclosure of XSA-108. A number of providers have interpreted the notice differently which has required further investigation, however we can confirm that we will be carrying out essential updates. Whilst this work is being carried out customer servers will be migrated between Hypervisors. We apologise any inconvenience this may cause, please continue to monitor this case for information.
Posted Oct 01, 2014 - 18:41 BST

Monitoring

A Xen security advisory (XSA-108) which is currently under embargo is due to be announced today and once details of the vulnerability have been made public, it may be essential for us to perform emergency maintenance to upgrade the Hypervisors on our London Cloud Platform.

When this work is being carried out, customer servers will be hot-migrated to alternative Hypervisors outside of working hours to facilitate the upgrades. In the unlikely event that a server does not support hot migration functionality or if a hot migration fails, the individual server will be powered off, migrated and booted on an alternative Hypervisor.

This case will be updated during the day once further information from Xen has been made available. If upgrades are required, we will confirm when this work is due to take place, however it is likely to take place within 24 hours.
Posted Oct 01, 2014 - 09:06 BST