XPControl - Service Unavailable

Incident Report for Xperience

Resolved

The platform vendor has confirmed the issue is now resolved.
Posted Feb 23, 2026 - 20:21 GMT

Update

The fix is still being worked on by the platform vendor, and no further updates will be posted here until it is resolved.
Posted Feb 23, 2026 - 18:51 GMT

Update

There are no further updates from the platform vendor at this time; they are still working on a fix.
Posted Feb 23, 2026 - 16:31 GMT

Update

The platform Vendor has identified the issue and is working on a fix.
Posted Feb 23, 2026 - 15:34 GMT

Update

The platform vendor has acknowledged the issue, and has advised their Cloud Ops team are currently investigating.
Posted Feb 23, 2026 - 14:47 GMT

Identified

An issue with the XPControl platform has been identified and is affecting Remote Control sessions - this has been raised with the platform vendor.

Further updates will be posted here as soon as we receive them from the platform vendor.
Posted Feb 23, 2026 - 14:41 GMT
This incident affected: XPControl Platform.