XPControl Platform - Degraded Performance

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 14:35 GMT

Monitoring

The platform vendor has confirmed resolution of the issue - we will monitor and update accordingly.
Posted Mar 16, 2026 - 11:23 GMT

Identified

An issue with the XPControl platform has been identified by the platform vendor, which is affecting Remote Control sessions.

Further updates will be posted here as soon as we receive them from the vendor.
Posted Mar 16, 2026 - 10:40 GMT
This incident affected: XPControl Platform.