Meridian Cloud Platform - Degraded Performance

Incident Report for Xperience

Resolved

We've been closely monitoring the issue, and the system is currently stable. We've identified the root cause and are preparing to implement a fix.
To minimize any potential disruption, the fix will be deployed during off-peak hours tonight.

We do not anticipate providing further updates on this issue today unless the situation changes.

We will post a separate update later, regarding any disruption the fix may cause during off-peak hours.
Posted Sep 04, 2025 - 09:39 BST

Identified

An issue has been identified which is currently impacting our Meridian Cloud Platform, causing some performance issues to a subset of virtual machines.

Our engineers are working on the issue and an update will be provided within the next 90 mins.
Posted Sep 04, 2025 - 08:07 BST
This incident affected: Meridian Cloud Platform.