Xperience SpamTitan - Degraded Performance

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 12:31 BST

Investigating

An issue has been identified which is currently impacting our SpamTitan infrastructure. Access to the service was impacted between 10:40am and 11am. Mail flow may have been delayed during this outage however is currently flowing now. We are currently investigating the cause.
Posted Jun 26, 2025 - 11:12 BST
This incident affected: Xperience SpamTitan.