LON Cloud Platform - Degraded Performance

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 16:19 BST

Update

We are continuing to monitor for any further issues.
Posted Jul 25, 2025 - 16:19 BST

Monitoring

The platform has been stabilized and all services are operational - a maintenance window will be announced for this evening to rectify the root cause of the issue.
Posted Jul 25, 2025 - 16:12 BST

Update

We are starting to stabilise the platform and getting resources back online, but still seeing some degraded performance across the platform, which we are working diligently to rectify.

We will continue to post updates here every hour until resolved.
Posted Jul 25, 2025 - 14:55 BST

Update

We are still working on the issue.
Posted Jul 25, 2025 - 14:32 BST

Identified

An issue has been identified which is currently impacting our Meridian (LON) Cloud Platform, and affecting some customer virtual infrastructure .
Our engineers are investigating the issue and an update will be provided within the next 60 mins.
Posted Jul 25, 2025 - 13:29 BST
This incident affected: Meridian Cloud Platform.