Lisburn Head Office - Telephone Issues
Incident Report for Xperience
Resolved
We're pleased to confirm that this issue has now been resolved.
Posted Jun 21, 2019 - 15:24 BST
Identified
Calls to our Lisburn office are currently impacted due to a third party failure. Should you need support whilst our team are working to address the issue, please email support@xperience-group.com or submit a ticket via our online portal at https://support.xperience-group.com.
Posted Jun 21, 2019 - 15:11 BST