XPControl Platform - Outage

Incident Report for Xperience

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 10:08 BST

Monitoring

The platform vendor has implemented a fix and services are returning to normal.
Posted Jun 09, 2026 - 09:24 BST

Update

We are continuing to work on a fix for this issue.
Posted Jun 09, 2026 - 08:52 BST

Identified

An issue with the XPControl platform has been identified and is affecting Remote Control sessions - this has been raised with the platform vendor.

Further updates will be posted here as soon as we receive them.

If you no longer wish to receive these updates, or would like to update your preferences, please visit https://status.xperience-group.com and click 'subscribe to updates'.
Posted Jun 09, 2026 - 08:48 BST
This incident affected: XPControl Platform.